Weapon attacking for no reason - mobile

Before i begin, i would like to thank the acknowledgement of my previous post and the fixing of bows on mobile. Not only this, but i believe a few bugs were fixed. There is, however a new one that has appeared on mobile. This isn’t so much a bug as it is something that just makes life harder and makes playing the game slightly more frustrating. For whatever reason, any touching of the screen causes your weapon to attack. Opening your inventory? weapon attacks. Eating a sub? weapon attacks. Tapping the jump button? weapon attacks. Usually this isn’t a huge problem but as an assassin there are two main scenarios in which this becomes really annoying:

  • Wasting arrows for no reason.

  • Jumping with shadow walk means your weapon attacks, causing shadow walk to break when you don’t want it to.

I’m really unsure as to why this is happening but i hope it’s something that can be fixed, thanks.

Yes everyone, i play on mobile, i basically always have, y’all can bully me if you want but i will always defend the right of the mobile community, however small it may be :joy:. just call me mobile guy.

Holding a button for a second and then letting it go doesn’t make the weapon attack for me.

I’ve tried my ranger slot on mobile once the fix came out and yes, it does waste arrows when you don’t want it to.

yeah i just tried it and it does seem to work, but that makes swapping weapons and going through your inventory take way longer, so chances are i won’t even really use this.