Camera desync while on wayfarer

I had gotten on the wayfarer to go to Forsaken this afternoon. As soon as i joined the server, it seemed like all scripts had broken. It spawned everyone in the middle of the water, where I assume is the center of the map, all in a stack. Our Roblox avatars were loaded and not our Vesteria characters, and water physics were also the default water physics Roblox has. After around 20 seconds the game “arriving” screen appeared. Once the game finished loading, everyone’s camera was stuck in place. I assume that only the camera was locked, because the stamina bar showed response to sprinting and jumping.

Until now, this had never happened to me on the Wayfarer or any other zone when loading. I don’t know what caused this, and if it is limited to the Wayfarer or if it can happen in other zones.

Here is a screenshot of the F9 log.


Edit: I believe my mouse is covering a 4
I do not know if anyone else has experienced this bug before, because I have not seen any mention of this on the forums or on Discord.

Update: On 1/8/2020 I had a similar issue, where the camera started in the water. However, the game did not load my Roblox avatar and after around 5 seconds, the game loaded in without any camera issues and the rest of the ride was normal. The exact same error from before was also present.

Never tried this before, but I wanna ask: did you make it to the isle in the end?

Yes, I did make it to the isle. It seemed to only affect my camera once the game loaded.

Weird.